Back to overview
Downtime
API Outage
Nov 18 at 09:24am EST
Affected services
Global RPC - CosmosHub
Global RPC - Osmosis
Global RPC - Celestia
Global RPC - Injective
Global RPC - Terra
Global RPC - Neutron
Global RPC - Seda
Resolved
Nov 18 at 02:00pm EST
CloudFlare systems operational
Affected services
Created
Nov 18 at 09:24am EST
Global Cloudflare outage affecting global geo-routing and load balancing
Affected services